在对 Angular 的文档 aio 进行编译的时候提示错误

error [email protected]: The engine "yarn" is incompatible with this module. Expected version ">=1.10.1 <1.14.0". Got "1.14.0"
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
C:\Users\Yucheng\Documents\WorkDir\Repository\Angular\angular-cn\aio\node_modules\yargs\yargs.js:1078
else throw err
^

 

根据错误的提示是 Yarn 的版本过高了。

请需要根据提示使用 Yarn 1.13 版本就可以了。我们在 aio 文档进行编译的时候,发现如果 yarn 的版本过高的话是没有办法编译成功的,因此请不要按照过高的 yarn 版本。

您可以在保留原文链接的情况下转载:HoneyMoose » 在对 Angular 的文档 aio 进行编译的时候提示错误

赞 (0) 打赏

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏