手动升级 Confluence 6 – 升级以后

7. 重新安装服务(仅针对 Windows)

如果你的 Confluence 安装实例在 Windows 中是以服务来运行的话,你需要删除已经存在的 Windows 服务,然后重新安装 Windows 服务。可以通过运行 <install-directory>/bin/service.bat 来进行安装。

请确定你的服务获得最新的 JVM 选项。

8. 重新应用任何修改

如果你对你的 Confluence 安装实例进行了自定义(例如对 SSL 进行了配置,在 server.xml 文件中,或者在 confluence-init.properties 文件中配置了 CATALINA_OPTS 或者 JAVA_OPTS 参数 ),你需要在你安装完成后执行后面的操作:

  1. 停止你已经升级的 Confluence 安装实例。
  2. 在你新的 Confluence 安装实例的安装目录中应用相关的自定义文件。
  3. 重新启动更新后的 Confluence 实例。

我们强烈建议,在对这些配置应用到生产环境之前,在测试环境中对你的自定义配置进行测试,以确定这些自定义的配置能够没有问题的应用到新的 Confluence 版本中。

9. 更新你的反向代理然后检查访问 Confluence

如果你正在计划从 Confluence 5.x 升级 Confluence 6.x 你需要修改你的服务器反向代理(如果你使用了的话),并且添加 Synchrony,Synchrony 在协同编辑中使用。请参考 Proxy and SSL considerations 页面中的内容来获得更多的信息,你需要对你的反向代理来进行配置。一旦你的升级完成,你将可用访问 Confluence(通过代理访问,不是直接访问)并且:

  • 进入  > 基本配置(General Configuration) > 协同编辑(Collaborative editing) 然后检查 Synchrony 的状态是否在运行(running)
  • 对任何页面在浏览器中进行编辑,并且确定你能够连接 Synchrony。

如果 Synchrony 没有运行或者你可以在编辑器中查看到错误,请访问 Troubleshooting Collaborative Editing 页面获得建议的修改步骤,有可能是你的反向代理没有配置正确。

https://www.cwiki.us/display/CONF6ZH/Upgrading+Confluence+Manually

您可以在保留原文链接的情况下转载:HoneyMoose » 手动升级 Confluence 6 – 升级以后

赞 (0) 打赏

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏